03-树2 List Leaves
2019-10-02 14:16:23
本文总阅读量

这道题花费了我四个小时,但是很开心一次AC,记录一下。花这么长时间的主要原因是,在第一次想的时候在构造树的结点的时候,没有加入结点的下标,导致后面越做越麻烦,好在及时修改,只花了4个小时😁😁。

题目描述

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
1
2
3
4
5
6
7
8
9
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
1
4 1 5
AC代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
#include<iostream>
#include<vector>
using namespace std;
#define Null -1
#define MAXSIZE 10
typedef struct BiTNode
{
int lchild;
int rchild;
int index;
}BiTNode;
typedef BiTNode QElemType;
typedef struct SqQueue
{
QElemType Data[MAXSIZE];
int front;
int rear;
}SqQueue;
int CreateBiTree(vector<BiTNode> &v, int n, int &leaves);
void InitQueue(SqQueue &Q);
void AddQueue(SqQueue &Q, BiTNode e);
void DeleteQueue(SqQueue &Q);
bool QueueEmpty(SqQueue Q);
bool QueueFull(SqQueue Q);
int main()
{
int n;
cin >> n;
int root;
vector<BiTNode> v;
int leaves = 0;
root = CreateBiTree(v, n, leaves);
SqQueue Q;
InitQueue(Q);
AddQueue(Q, v[root]);
int cnt = 0;
while (!QueueEmpty(Q))
{
if (Q.Data[Q.front].lchild == Null && Q.Data[Q.front].rchild == Null)
{
cnt++;
if (cnt == leaves)
cout << Q.Data[Q.front].index;
else
cout << Q.Data[Q.front].index << " ";
}
int t = Q.Data[Q.front].index;
DeleteQueue(Q);
if (v[t].lchild != Null)
AddQueue(Q, v[v[t].lchild]);
if (v[t].rchild != Null)
AddQueue(Q, v[v[t].rchild]);
}

return 0;
}
int CreateBiTree(vector<BiTNode> &v, int n, int &leaves)
{
char l, r;
BiTNode tmp;
vector<int> arr(n, 1);
for (int i = 0; i < n; i++)
{
tmp.index = i;
cin >> l >> r;
if (l == '-')
tmp.lchild = Null;
else
{
tmp.lchild = l - '0';
arr[tmp.lchild] = 0;
}
if (r == '-')
tmp.rchild = Null;
else
{
tmp.rchild = r - '0';
arr[tmp.rchild] = 0;
}
if (tmp.lchild == Null && tmp.rchild == Null)
leaves++;
v.push_back(tmp);
}
int i = 0;
for (; i < n; i++)
{
if (arr[i] != 0)
break;
}
return i;
}
void InitQueue(SqQueue &Q)
{
Q.front = 0;
Q.rear = 0;
}
void AddQueue(SqQueue &Q, BiTNode e)
{
if (!QueueFull(Q))
{
Q.Data[Q.rear] = e;
Q.rear = (Q.rear + 1) % MAXSIZE;
}
}
void DeleteQueue(SqQueue &Q)
{
if (!QueueEmpty(Q))
{
Q.front = (Q.front + 1) % MAXSIZE;
}
}
bool QueueEmpty(SqQueue Q)
{
if (Q.front == Q.rear)
return true;
return false;
}
bool QueueFull(SqQueue Q)
{
if ((Q.front + MAXSIZE - Q.rear) % MAXSIZE == 1)
return true;
return false;
}